Page 1 of 1

Radio reception . . .

PostPosted: Fri Oct 07, 2011 6:15 pm
by Fiddytree
disappears when rear window defroster in on.

Common?

Cure?

thanks,

Re: Radio reception . . .

PostPosted: Wed Oct 12, 2011 3:55 pm
by 4banger
When I was removing my interior I noticed the antenna box thing and connectors to the rear window were also infused with the rear defrosters. you can pull the panels between the rear and side windows to check if anything may be loose

Re: Radio reception . . .

PostPosted: Thu Oct 13, 2011 4:35 am
by Caligula
Agreed, your radio antenna is in part the rear glass defroster lines.

Re: Radio reception . . .

PostPosted: Thu Oct 13, 2011 6:38 am
by Fiddytree
In that case, there will probably NEVER be radio w/ the defroster on.

Thanks!

Re: Radio reception . . .

PostPosted: Thu Oct 13, 2011 11:01 am
by e36-coupe
suprises me bmw did this, the way bmw design and manafactur there cars, they overlooked something like this, and the fact it didnt arise as a common problem for dealers to rectify when new

unless you have something like this?

http://www.ebay.co.uk/itm/Car-Digital-D ... 3cbc888ecb

or slightly more expensive, but known brand

http://www.ebay.co.uk/itm/Blaupunkt-Aut ... 5d30ac346e

Re: Radio reception . . .

PostPosted: Sun Dec 16, 2012 2:36 pm
by stefan
Hey guys, sorry for bringing up an old topic, but my car does the same thing; as soon as I turn on the defroster, it's like the antenna is shut off.
I don't have any loose wires or cores touching due to stripped isolation or whatever, so I'm kinda lost here... could it be the lines in the window are at fault?
Unfortunately, I don't really know my way around electronics, it's always been like produce of magic pixies and unicorns to me, so I haven't been able to measure anything (because I don't know what else to measure other than "does it have 12v or not").

I owned a e32 before the e36 that had the same integrated antenna and both the antenna and defroster worked perfect at the same time, so I don't think it's by design, and it annoys/bothers the heck out of me and would like to get it back to work without adding aftermarket electronics like the two options above...

Re: Radio reception . . .

PostPosted: Mon Dec 17, 2012 5:43 pm
by e36-coupe
the problem is that when they printed the first batch of screens there was an error. Somewhere, the defrost and imbeded antena touch. Have a good look at the defrost lines, follow every line one by one and you'll find where they touch. Once you do, all you have to do is scratch off the part that links both systems together.

0r try here

http://forum.e46fanatics.com/showpost.p ... ostcount=8


0r g00gle search

https://www.google.co.uk/webhp?sourceid ... 80&bih=675

Re: Radio reception . . .

PostPosted: Thu Dec 20, 2012 6:22 am
by stefan
Thanks! I've been looking into it some more, and I found this post on a British forum;
I have had this problem on my last car, an E36 323i Coupe, and also in an E39 520i prior to that, believe it or not it has reared it's head in my present E39 540i Sport. The problem is inherent in the majority of BMW's, except for convertibles. The antenna for the radio is located in the rear window and in some Tourings (estates) in the rear most side windows. What looks like a very complicated rear window demister element in the rear window glass also incorporates the radio antenna. All vehicles that I know of have a "Radio Signal Amplifier" mounted somewhere near the antenna, in an E39 Saloon it is behind the trim on the left hand rear "C" Pillar, this is the location on E36 & E46 also. I went to the trouble of getting a used amplifier for my E36, but found that after I had disconnected it, cleaned the connections and earths it worked perfectly. I have yet to tackle my present E39. It is a relatively simple job to do, just takes longer to get to the amplifier than the cleaning etc. just be patient with trim panels, removing can cause damage.

Source: http://www.bmwland.co.uk/forums/viewtop ... 6#p1075047
So I guess I'll be trying this when I'm in there to look at the lines to see if they're not touching or whatever.

Also, the link to the e46 new style amplifier thread doesn't apply to the e36, the amplifier is very different... here is a random pic of a e36 amp:
Image
And here are the two styles of e46 amps:
Image

And; my car is a mid-'96 model, we got the first e36's in 1991... I don't think my rear window is from the first batch, but I'll check for -touching- :mrgreen: